Перейти к содержимому


Фотография
- - - - -

Как перенести форум на HTTPS-протокол


  • Авторизуйтесь для ответа в теме
В теме одно сообщение

#1 Оффлайн   iWork

    Новичок


  • Пользователи
  • Репутация
    0
    • Cообщений: 6
    • Форум:3.4.х
    • Город:Sochi

Отправлено 14 Июнь 2017 - 17:59

Здравствуйте! как правильно перенести форум на HTTPS протокол.

Сертификат подключен. он работает когда авторизируешься в админ-панели.

Но не работает на основном форуме, как сделать правильно и подключить ?

 

Прописал в conf_global и в htacces

Что прописал в .htaccess

Скрытый текст

 

по итогам вот ошибку выдает при переходе в котегории или вообще куда либо

Прикрепленный файл  Снимок.PNG   27,95К    скачиваний 2

 

Делал все по мануалу:

решение:

1. Сертификат

2. В АЦ - Настройки - Настройки безопасности - Использовать https протокол для форм входа? ставим ДА

3. В конфиге меняем http на https пример: $INFO['board_url'] = 'https://Сайт нарушает авторские права';

4. В файле .htaccess прописываем редирект перехода со старых ссылок на новые

RewriteEngine On
RewriteCond %{SERVER_PORT} !^443$
RewriteRule .* https://%{SERVER_NAME}%{REQUEST_URI} [R=301,L]

скриншот проблемы выше в теме


Сообщение отредактировал iWork: 14 Июнь 2017 - 19:41

  • 0

#2 Оффлайн   iWork

    Новичок


  • Пользователи
  • Репутация
    0
    • Cообщений: 6
    • Форум:3.4.х
    • Город:Sochi

Отправлено 14 Июнь 2017 - 20:39

Изменив запрос в htaccess страница появилась, но уже без дизайна.

В шаблонах вроде везде заменил на HTTPS

 

Прикрепленные файлы


  • 0