Перейти к содержимому


Фотография
- - - - -

Перенос форума с домена второго уровня на первый


  • Закрытая тема Тема закрыта
Сообщений в теме: 7

#1 Оффлайн   kia112233

    Пользователь


  • Заблокированные
  • Репутация
    2
    • Cообщений: 18
    • Форум:3.1.4

Отправлено 20 Декабрь 2012 - 16:27

Перенос вроде прошел успешно, форум открывается по новому адресу, но когда пытаешься открыть в нем форум или тему, то он перебрасывает на главную сайта.

Было

http://форум.сайт.ru

 


стало и все открывается

 

 

http://сайт.ru/форум/

 

 


но когда жмем  например на тему имеющую линк

 

 

http://сайт.ru/форум/topic/5063/

 


то попадаем на

 

 

http://сайт.ru/

 


никаких редиректов нет, в адресной строке висит

 

 

http://сайт.ru/форум/topic/5063/

 


а мы на

 

 

http://сайт.ru/

 


что надо поправить? подскажите плиз?

По админке ползаем без проблем и никуда не выкидывает.


Сообщение отредактировал ๖ۣۣۜDesperate™: 08 Февраль 2013 - 05:55


#2 Оффлайн   Reba The Awesome

    Легенда


  • Пользователи
  • Репутация
    219
    • Cообщений: 1 065
    • Форум:3.4.х

Отправлено 20 Декабрь 2012 - 16:41

Исправьте путь сайта в conf_global.php

И перестройте FURL кэш, а также все кэши.


  • 0

#3 Оффлайн   kia112233

    Пользователь


  • Заблокированные
  • Репутация
    2
    • Cообщений: 18
    • Форум:3.1.4

Отправлено 20 Декабрь 2012 - 16:53

Исправьте путь сайта в conf_global.php

И перестройте FURL кэш, а также все кэши.

Исправил и перестроил все сразу после переноса, иначе бы форум не открылся по новому адресу.

 

при наведении курсора на какой нить форум или тему - показывается правильная ссылка, то есть:

 

 

 

Пожалуйста Войдите или Зарегистрируйтесь чтобы видеть скрытое содержание

однако перебрасывает на главную сайт, как я уже и писал... :)



#4 Оффлайн   kia112233

    Пользователь


  • Заблокированные
  • Репутация
    2
    • Cообщений: 18
    • Форум:3.1.4

Отправлено 20 Декабрь 2012 - 19:03

Если же отключить .htaccess mod_rewrite

 

то на главную сайта уже не перебрасывает, пишеь следующее:

 

 

Неверное перенаправление на странице
          Firefox определил, что сервер перенаправляет запрос на этот адрес таким образом, что он никогда не завершится.
       Эта проблема может возникать при отключении или запрещении принятия кук.


#5 Оффлайн   kia112233

    Пользователь


  • Заблокированные
  • Репутация
    2
    • Cообщений: 18
    • Форум:3.1.4

Отправлено 20 Декабрь 2012 - 19:11

Следующий ньюанс, если в conf_global.php

 

 

$INFO['use_friendly_urls'] = '1';

 

  единичку за менить на 0, то ЧПУ отключается и все работает, то есть переходит как надо и никуда не выкидывает. Но у меня вопрос - почему не работает сЧПУ и выкидывает на главную сайт и как это починить?


Сообщение отредактировал kia112233: 20 Декабрь 2012 - 19:11


#6 Оффлайн   Reba The Awesome

    Легенда


  • Пользователи
  • Репутация
    219
    • Cообщений: 1 065
    • Форум:3.4.х

Отправлено 20 Декабрь 2012 - 19:24

может быть что ограничения хоста.


  • 0

#7 Оффлайн   kia112233

    Пользователь


  • Заблокированные
  • Репутация
    2
    • Cообщений: 18
    • Форум:3.1.4

Отправлено 20 Декабрь 2012 - 19:30

может быть что ограничения хоста.

Что за ограничения? все на одном хосте



#8 Оффлайн   kia112233

    Пользователь


  • Заблокированные
  • Репутация
    2
    • Cообщений: 18
    • Форум:3.1.4

Отправлено 20 Декабрь 2012 - 19:51

Если же отключить .htaccess mod_rewrite

 

Блин ! разобрался !!))))

 

В htaccess вместо

RewriteRule . /index.php [L]

 

надо было указать

RewriteRule . /форум/index.php [L]

 

:)