Перейти к содержимому


Фотография
- - - - -

Формирование ссылки на сообщение


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 3

#1 Оффлайн   sudya

    Пользователь


  • Пользователи
  • Репутация
    1
    • Cообщений: 36
    • Форум:3.4.х

Отправлено 26 Февраль 2013 - 07:15

Добрый вечер.

 

Обнаружилась такая вот проблема.

Есть например тема, которую модерируют модераторы и например скрыли много сообщений, обычные пользователи эти сообщения не видят.

И тут модератор в теме кидает ссылку на пост, в котором уже поднимался вопрос, но обычный юзер кликая на ссылку получает ошибку, мол такого не можем найти, обратитесь к администратору. Было выявлено что в ссылке присутствует параметр /index.php?showtopic=202020&st=700#entry1071811124, если ссылку размещает модератор, то получается /index.php?showtopic=202020&st=700#entry1071811124, а если обычный юзер, то /index.php?showtopic=202020&st=630#entry1071811124 в итоге модераторы не могут перейти по ссылке юзера, изеры по ссылке модератора.

 

Поиском ничего не нашел, подскажите куда копать? просто избавиться от параметра не дает нужного результата, кидает в начало темы

 


  • 0

Заработок и обучение заработку

#2 Оффлайн   ๖ۣۣۜDesperate™

    Администратор


  • Администраторы
  • Репутация
    4 611
    • Cообщений: 8 556
    • Форум:3.4.х
    • Город:IpbZona
    Участник

Отправлено 26 Февраль 2013 - 07:39

Попробуйте настроить ЧПУ


  • 0

#3 Оффлайн   sudya

    Пользователь


  • Пользователи
  • Репутация
    1
    • Cообщений: 36
    • Форум:3.4.х

Отправлено 27 Февраль 2013 - 04:58

Не помогло, запись st=700 осталась в ссылке


  • 0

#4 Оффлайн   ๖ۣۣۜDesperate™

    Администратор


  • Администраторы
  • Репутация
    4 611
    • Cообщений: 8 556
    • Форум:3.4.х
    • Город:IpbZona
    Участник

Отправлено 27 Февраль 2013 - 08:23

У вас какой версии форум? Если обновлялись с более ранних и у вас 3.4.2 то попробуйте патч


  • 0