Перейти к содержимому


Фотография
- - - - -

Проблема с UserInfoPane


  • Закрытая тема Тема закрыта
Сообщений в теме: 5

#1 Оффлайн   NetTomsk

    Новичок


  • Пользователи
  • Репутация
    0
    • Cообщений: 3
    • Форум:3.3.х
    • Город:Томск

Отправлено 18 Март 2013 - 13:39

Привет всем!


Вообщем проблема заключается в том, что при оформлении, вставки кода:

<div itemscope itemtype="http://schema.org/Person" class='user_details'>
<span class='hide' itemprop="name">{$author['members_display_name']}</span>
<ul class='basic_info'>
<if test="membertitle:|:$author['member_title']">
<p class='desc member_title'>{$author['member_title']}</p>
</if>
<if test="avatar:|:$author['member_id']">
<li class='avatar'>
<if test="canSeeProfiles:|:$this->memberData['g_is_supmod'] OR ( $this->memberData['g_mem_info'] && ! IPSMember::isInactive( $author ) )">
<a itemprop="url" href="{parse url="showuser={$author['member_id']}" template="showuser" seotitle="{$author['members_seo_name']}" base="public"}" title="{$this->lang->words['view_profile']}: {$author['members_display_name']}" class='ipsUserPhotoLink'>
</if>
<if test="hasVariable:|:$this->settings['member_topic_avatar_max']">
	 <img itemprop="image" src='{$author['pp_main_photo']}' class='ipsUserPhoto ipsUserPhoto_variable' />
<else />
	 <img itemprop="image" src='{$author['pp_thumb_photo']}' class='ipsUserPhoto ipsUserPhoto_large' />
</if>
<if test="canSeeProfiles2:|:$this->memberData['g_is_supmod'] OR ( $this->memberData['g_mem_info'] && ! IPSMember::isInactive( $author ) )">
</a>
</if>
</li>
<else />
<li class='avatar'>
<img itemprop="image" src='{$author['pp_thumb_photo']}' class='ipsUserPhoto ipsUserPhoto_large' />
</li>
</if>
<li class='group_title'>
{$author['_group_formatted']}
</li><br/>
<if test="rankimage:|:$author['member_rank_img']">
<li class='group_icon'>
<if test="rankimageimage:|:$author['member_rank_img_i'] == 'img'">
<img src='{$author['member_rank_img']}' alt='' />
<else />
{$author['member_rank_img']}
</if>
</li>
</if>
<if test="postCount:|:$author['member_id']">
</if>
<if test="authorwarn:|:$author['show_warn']">

</if>
</ul>
<if test="authorcfields:|:$author['custom_fields'] != """>
<ul class='custom_fields'>
<foreach loop="customFieldsOuter:$author['custom_fields'] as $group => $data">
<foreach loop="customFields:$author['custom_fields'][ $group ] as $field">
	 <if test="$field != ''">
	 <li>
	 {$field}
	 </li>
	 </if>
</foreach>
</foreach>
		 <li>
		 <table width="100%" border="0">
			 <tr>
			 <td width="18"><img src="http://Ваш_сайт/public/style_extra/cprofile_icons/text.png"></td>
			 <td width="50" align="left">Сообщений:</td>
			 <td align="left">{parse exp<b></b>ression="$this->registry->getClass('class_localization')->formatNumber( intval( $author['posts'] ) )"}</td>
			 </tr>
		 </table>
		 </li>
<li>
		 <table width="100%" border="0">
			 <tr>
			 <td width="18"><img src="http://Ваш_сайт/public/style_extra/cprofile_icons/warns.png"></td>
			 <td width="50" align="left"><a class='desc lighter blend_links' href='{parse url="app=members&amp;module=profile&amp;section=warnings&amp;member={$author['member_id']}&amp;from_app={$this->request['app']}&amp;from_id1={$contentid}&amp;from_id2={$options['id2']}" base="public"}' id='warn_link_{$contentid}_{$author['member_id']}' title='{$this->lang->words['warn_view_history']}'>Предупреждений:</a></td>
			 <td align="left"><b>{parse exp<b></b>ression="sprintf( $this->lang->words['warn_status'], $author['warn_level'] )"}</b></td>
			 </tr>
		 </table>
		 </li>
</ul>
</if>
</div>

 

форум не загружается, пишет 

Ошибка HTTP 500 (Internal Server Error): При попытке сервера выполнить запрос возникла неожиданная ситуация.

 

В логах

2013/03/18 12:21:13 [error] 3409#0: *6495 FastCGI sent in stderr: "PHP Parse error:  syntax error, unexpected T_ENCAPSED_AND_WHITESPACE, expecting T_STRING or T_VARIABLE or T_NUM_STRING in /sources/classes/output/publicOutput.php(1722) : eval()'d code on line 1414
PHP Fatal error:  Class 'skin_global_5' not found in /sources/classes/output/publicOutput.php(3536) : eval()'d code on line 2" while reading response header from upstream, client: 188.162.14.66, server: localhost, request: "GET / HTTP/1.1", upstream: "fastcgi://127.0.0.1:1989", host: "localhost"

 

В чем может быть проблема?


  • 0

Заработок и обучение заработку

#2 Оффлайн   ..ツ⋆WOLF⋆ツ..

    Гуру


  • Модераторы
  • Репутация
    1 799
    • Cообщений: 8 168
    • Форум:3.4.х
    • Город:Казань

Отправлено 18 Март 2013 - 21:07

откуда взяли код вообще?


  • 0

#3 Оффлайн   NetTomsk

    Новичок


  • Пользователи
  • Репутация
    0
    • Cообщений: 3
    • Форум:3.3.х
    • Город:Томск

Отправлено 18 Март 2013 - 23:46

откуда взяли код вообще?

Не помню, искал в интернете и нашел его.


  • 0

#4 Оффлайн   ๖ۣۣۜDesperate™

    Администратор


  • Администраторы
  • Репутация
    4 611
    • Cообщений: 8 556
    • Форум:3.4.х
    • Город:IpbZona
    Участник

Отправлено 18 Март 2013 - 23:48

Если хотите использовать свой дизайн, то проще используй те стандартный код и уже ковыряйете его! У нас много вариантов как сделать красиво информацию пользователя.


  • 0

#5 Оффлайн   ..ツ⋆WOLF⋆ツ..

    Гуру


  • Модераторы
  • Репутация
    1 799
    • Cообщений: 8 168
    • Форум:3.4.х
    • Город:Казань

Отправлено 18 Март 2013 - 23:49

Не помню, искал в интернете и нашел его.

не занимайтесь фигней, раз выходит ошибка, значит код ошибочный, хотите поколдавать с UserInfopane то вот вам тема: http://ipbzona.ru/to...e-userinfopane/


  • 0

#6 Оффлайн   NetTomsk

    Новичок


  • Пользователи
  • Репутация
    0
    • Cообщений: 3
    • Форум:3.3.х
    • Город:Томск

Отправлено 19 Март 2013 - 01:48

Вместо того, чтобы тыкать пальцем на ссылки или считать себя "умным" лучше бы взяли да и помогли, мда.

Тему можно оффнуть.


  • 0