Перейти к содержимому


Фотография
- - - - -

Перенос форума


  • Авторизуйтесь для ответа в теме
Сообщений в теме: 11

#1 Оффлайн   Templar

    Продвинутый


  • Пользователи
  • Репутация
    0
    • Cообщений: 71
    • Форум:3.3.х

Отправлено 02 Апрель 2013 - 21:16

Всем привет народ перешел на новый хостинг, взял тупо копи паст форума с хостинга на хостинг, базу так же само , исправил пути где только можно, в итоге админка работает норм, а сам форум все равно идет коннект на старую БД, где то может я пропустил что-то? Может кто сталкивался с такой бедой?


  • 0

Заработок и обучение заработку

#2 Оффлайн   4-ARTs

    Новичок


  • Пользователи
  • Репутация
    1
    • Cообщений: 4
    • Форум:3.3.х

Отправлено 02 Апрель 2013 - 21:18

1. Любыми средствами создать на хостинге базу данных.
2. Имя базы данных, пароль и имя пользователя базы прописать в config_global.php
3. Зайти на ваш хостинг по ssh(!!!) Если он есть.
4. Найди место где лежит ваша база. Для Unix это может быть путь -- \var\db\mysql\имя базы
5. Скопировать все ваши файлы в эту директорию.
6. Выставить нужные права на все файлы. Пользователь - mysql Группа - mysql
Все.

 

Возможно из-за второго пункта у вас проблемы.


  • 1

#3 Оффлайн   Templar

    Продвинутый


  • Пользователи
  • Репутация
    0
    • Cообщений: 71
    • Форум:3.3.х

Отправлено 02 Апрель 2013 - 21:22

Спасибо будем смотреть 


  • 0

#4 Онлайн   ..ツ⋆WOLF⋆ツ..

    Гуру


  • Модераторы
  • Репутация
    1 799
    • Cообщений: 8 169
    • Форум:3.4.х
    • Город:Казань

Отправлено 02 Апрель 2013 - 21:22

как говорит 

4-ARTs 

у вас скорее не верно указаны данные в config_global.php


  • 0

#5 Оффлайн   Templar

    Продвинутый


  • Пользователи
  • Репутация
    0
    • Cообщений: 71
    • Форум:3.3.х

Отправлено 02 Апрель 2013 - 21:36

Проверил пути и доступы в файле conf_global.php . Всё совпадает с данными для новой базы на новом хостинге.

Админка работает без проблем, а как только заходишь на сам форум , пишет

 

Access denied for user 'host126_root'@'localhost' (using password: YES)

 

Хотя это старый пользователь на старом хостинге.

 

Ради интереса , меняю пароль для пользователя mysql ,на новом хостинге, специально на неправильный, то тогда вылетает :

 

Возникла ошибка при работе с базой данных.

 

Возвращаю обратно правильный пароль, то админка опять работает, а на форуме опять вылетает первая надпись.

 

Почистил весь кэш у форума. Всё равно одно и тоже. Куда копать дальше?


  • 0

#6 Онлайн   ..ツ⋆WOLF⋆ツ..

    Гуру


  • Модераторы
  • Репутация
    1 799
    • Cообщений: 8 169
    • Форум:3.4.х
    • Город:Казань

Отправлено 02 Апрель 2013 - 21:44

пересчет и обновление делали?


  • 0

#7 Оффлайн   Templar

    Продвинутый


  • Пользователи
  • Репутация
    0
    • Cообщений: 71
    • Форум:3.3.х

Отправлено 02 Апрель 2013 - 21:53

Только что специально пересчитал и обновился по всем пунктам и после этого перестроил весь кэш. Ошибка осталась прежняя:

 

Access denied for user 'host126_root'@'localhost' (using password: YES)

 

Я вот думаю, может где то в базе прописан пользователь этот? Хотя скачал дамп базы и через notepad++ попытался найти этого пользователя в дампе и конечно же не нашлось данных с этой строчкой поиска : host126_root

Следовательно и не в базе это прописано.

 

Куда еще посоветуете копнуть? 


  • 0

#8 Оффлайн   Templar

    Продвинутый


  • Пользователи
  • Репутация
    0
    • Cообщений: 71
    • Форум:3.3.х

Отправлено 02 Апрель 2013 - 23:01

Ну что не кто не сталкивался с такими проблемами? Просто черт его знает что и делать щас ...


  • 0

#9 Онлайн   ..ツ⋆WOLF⋆ツ..

    Гуру


  • Модераторы
  • Репутация
    1 799
    • Cообщений: 8 169
    • Форум:3.4.х
    • Город:Казань

Отправлено 02 Апрель 2013 - 23:02

отключите ваш форум на старом хостинге


  • 0

#10 Оффлайн   Templar

    Продвинутый


  • Пользователи
  • Репутация
    0
    • Cообщений: 71
    • Форум:3.3.х

Отправлено 02 Апрель 2013 - 23:15

Да вроде удален и база удалена и все равно его тянет все назад


  • 0