Перейти к содержимому


Фотография
- - - - -

Проблема с использованием внешней авторизации


  • Авторизуйтесь для ответа в теме
В этой теме нет ответов

#1 Оффлайн   xsis

    Новичок


  • Пользователи
  • Репутация
    0
    • Cообщений: 1
    • Форум:3.3.х
    • Город:Sochi

Отправлено 19 Июль 2013 - 11:56

Моим сайтом, на котором установлен и форум (IP Board 3.3.4), используется база данных, которая также задействована и в других важных модулях, таких как магазин, поэтому мне нужно чтобы и форум использовал основную базу данных сайта на dle 9.6. Я захожу в АЦ, в инструментах в "Модулях авторизации" ставлю внешнюю авторизацию с внешней базы данных, внутреннюю отключаю, далее пытаюсь зайти на форум с учётной записи, которая зарегистрирована только на сайте, и мне выдаёт ошибку базы данных:

 

 

 

 
SQL error: Access denied for user 'root'@'localhost' (using password: NO)
SQL error code: 1045
Date: Friday 19th July 2013 07:42:48 AM
 
 
 ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
 Date: Fri, 19 Jul 2013 07:42:48 +0000
 Error: 1045 - Access denied for user 'root'@'localhost' (using password: NO)
 IP Address: 88.87.93.213 - /forum/index.php?app=core&module=global&section=login&do=process
 ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
 
 .--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------.
 | File                                                                       | Function                                                                      | Line No.          |
 |----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------|
 | admin/sources/handlers/han_login.php                                       | [login_external].authenticate                                                 | 684               |
 '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
 | admin/sources/handlers/han_login.php                                       | [han_login].loginAuthenticate                                                 | 340               |
 '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
 | admin/applications/core/modules_public/global/login.php                    | [han_login].verifyLogin                                                       | 448               |
 '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
 | admin/applications/core/modules_public/global/login.php                    | [public_core_global_login].doLogin                                            | 107               |
 '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
 | admin/sources/base/ipsController.php                                       | [public_core_global_login].doExecute                                          | 306               |
 '----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'

 

При установке форума всю информацию про базу (основную, которая используется сайтом) данных писал верно, почему же доступ запрщен? Не исключено, что ошибся, всё бывает, где можно проверить логин и пароль основной базы данных? Или дело здесь не в базе?

 

И всё ли я делаю правильно, мне нужно, чтобы была лишь одна регистрация через сайт и после этого на форуме уже можно было авторизоваться. Прошу помощи, заранее спасибо.


Сообщение отредактировал xsis: 19 Июль 2013 - 11:57

  • 0